관리 메뉴

abctrend 트랜드 블로그

this will throw an Error in a future version of PHP 에러 해결법 본문

IT, 인터넷 트랜드/웹제작팁&테크

this will throw an Error in a future version of PHP 에러 해결법

Synergymaker 큐브엑스 2020. 12. 2. 20:55

this will throw an Error in a future version of PHP

PHP 5.4 이상 설치된 서버로 PHP 5.3이전 에서 개발한 소스를 올리면 에러를 출력하게 됩니다.
규칙이나 정규식을 엄격하게 구분하는 이유입니다.

Warning: Use of undefined constant __INCLUDE_CONFIG_PHP - assumed '__INCLUDE_CONFIG_PHP' (this will throw an Error in a future version of PHP) in /home/happyjung/www/incloud.lib.php on line 27

PHP 5.5 이후에는 정의되지 않은 상수를 사용하지 않아야합니다.
존재하지 않는 전역 상수 인 따옴표없는 문자열은 그 자체의 문자열로 간주됩니다.

수정전: 
define(__INCLUDE_CONFIG_PHP,"TRUE");

수정후:
define('__INCLUDE_CONFIG_PHP',"TRUE");

처럼 에러나는 부분의 앞뒤에 ''를 정확하게 해주시면 대부분의 에러가 해결됩니다

0 Comments
댓글쓰기 폼